Mitigation actions have been implemented and services are recovering from the major service disruption. We are monitoring systems to ensure stability and performance
Posted Apr 06, 2026 - 12:04 CDT
Identified
The cause of the major service disruption has been identified, and remediation efforts are underway. We will continue to provide updates as progress is made.
Posted Apr 06, 2026 - 11:41 CDT
This incident affected: Orchestration Layers (Prospera (Stocks/Digital Assets/Wealth) Platform).